Unexpected problem when creating requests in the Virtual Agent with MS Teams for Jira Service Management Cloud
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
When trying to raise requests via the Virtual agent from a MS Teams integration, the bot is returning the error:
There was an unexpected problem
An unexpected problem occurred, please contact Assist support using our support form https://www.atlassian.com/software/halp/contact in order to continue.
Cause
This error can occur if the Default request type field is empty in the Virtual agent settings.
To access the virtual agent settings:
- Access your JSM project
- Go to Project settings
- Navigate to Virtual service agent
- Basic settings tab
By default, when configuring the Virtual agent you need to specify a Default request type, however, if the request type specified is deleted, then the Virtual agent will lose it's value causing the issue.
Solution
Add a Default request type to the Virtual agent. For that:
- Access your JSM project
- Go to Project settings
- Navigate to Virtual service agent
- Basic settings tab
- Add a value to Default request type