Epics displaying as unlabeled in Jira server

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

There are epics in your Scrum and Kanban Boards that appear unlabelled. 

Cause

  • Jira has not been re-indexed after installing Jira Software.
  • Epic tickets were created before the Jira Agile 6.1+ was created. In Jira Agile 6.1+ there is a new custom field named Epic Name which is used to store the name displayed in Jira Agile.
  • Issue type Epic is not available within Epic Name custom field context.
  • Epic custom fields have missing customfieldsearcherkey
  • The project(s) and Epics have been imported from a Jira Cloud Environment. In Jira Cloud the Epic Name field is optional and, therefore may not contain a value.

Resolution

First, check the following:

  1. Jira was re-indexed after Jira Software was installed. If it was not, or you're uncertain, re-index Jira.
  2. Verify if the Epic issue type is available within Epic Name custom field context.
  3. Verify the epic fields are not affected by Fields missing from JQL auto complete due to missing customfieldsearcherkey 

If the above does not resolve the problem, there are known two ways to change the epic name.

  1. Click the three dots on the right side of the epic and choose Edit Name 


  2. Open the Issue detail view of the epic ticket and choose edit on the ticket. You should be presented with an option to change the Epic Name there.
Last modified on Mar 25, 2024

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