UNRESOLVED showing up as a Resolution for Resolved issues

Still need help?

The Atlassian Community is here for you.

Ask the community

Problem

When using the Issue Navigator to find issues, the Resolution status of Unresolved appears twice.

(info) For JIRA 4.1.x the statuses with the non-red Unresolved status are items that are using the custom added Unresolved status


Cause

This is caused when a custom Resolution status of Unresolved is added under Administration >> Issues >> Resolutions. When an issue is opened in JIRA, the default is that the Resolution field is empty - the term Unresolved is a system term that means the Resolution field has no value. Only when the Resolution field has no value does it appear with the system default Unresolved

All issues are considered unresolved until the Resolution field is given a value.

Solutions:

Workflow Method

If a duplicate resolution status appears in the Issue Navigator, remove it via the following steps:

  1. Modify the workflow to add a loop transition for affected status. In the transition, add an Update Issue Field post function to set the Resolution field to None.
    1. For this step you'll want to add a Transition in your Open step that will lead back to the Open step
    2. That is the step where you will need to assign the Update Issue Field post function to set Resolution to None
  2. In the issue navigator, search for the issues with the Resolution set to unresolved. (i.e. the custom unresolved status or whichever one shows up black and not in all caps)
    (info) One way to make the distinction a little easier between the resolutions is to change the Unresolved status to a different name
  3. Do a bulk transition using the transition set in step 1.
  4. If necessary, repeat the above steps for each affected status.
  5. Revert the changes made in step 1 to clean up the workflows.
  6. Remove the unresolved status listed under Administration >> Issues >> Issue Attributes >> Resolutions

Script Runner Method (third party add-on)

This is an alternate method to clear resolutions on tickets

  1. Install the Script Runner add-on
  2. Build a search for all issues that are using the user created unresolved status
  3. Save search as a filter
  4. Navigate to Add-ons, scroll down to SCRIPT RUNNER and select Built-in Scripts
  5. Select the Bulk Fix Resolutions, use the saved filter, and select none as the new resolution.
  6. Remove the unresolved status listed under Administration >> Issues >> Issue Attributes >> Resolutions

Full Script Runner usage instructions: https://jamieechlin.atlassian.net/wiki/display/GRV/Built-In+Scripts#Built-InScripts-BulkFixResolutions

Last modified on Mar 21, 2024

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.