Unresolved showing up as a Resolution for Resolved issues

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Problem

When using the Issue Navigator to find issues, the Resolution status of Unresolved appears twice, one of them being italicized.

Cause

This is caused when a custom Resolution value of Unresolved is added under Administration >> Issues >> Resolutions. When an issue is opened in JIRA, the default is that the Resolution field is empty - the term Unresolved is a system term that means the Resolution field has no value. Only when the Resolution field has no value does it appear with the system default Unresolved

Reference documentation on managing Resolutions can be found on this link.

  • We have a warning on that page:

Don't create a Resolution named "Unresolved"/"None"

Any issue that has the Resolution field set is treated by Jira applications as "resolved". The Issue Navigator displays Unresolved when no resolution is set for an issue. So adding a resolution named Unresolved/None and setting it in an issue will mean that the issue is seen as resolved. This will lead to confusion and is not recommended. 

Solution

If you'd like to replace custom Unresolved with another resolution

On this case, the first step is to delete the "Unresolved" resolution resolution on Administration >> Issues >> Resolutions. Jira will request what value of resolution you'd like to migrate these issues to.

Next, you need to find the sources that were bringing issues into the custom "Unresolved" resolution.

  • If users were selecting that from a drop-down list in a screen then no further action is needed as the value will no longer be available.
  • If the resolution was being set to "Unresolved" as a post-function, you'll need to edit the workflow transition to set a proper value.

If you'd like to clear the Unresolved resolution to reflect the system Unresolved

Workflow Method

If a duplicate resolution status appears in the Issue Navigator, remove it via the following steps:

  1. Modify the workflow to add a loop transition for affected status. In the transition, add an Update Issue Field post function to set the Resolution field to None.
  2. In the issue navigator, search for the issues with the Resolution set to the custom Unresolved.  You can find them using this JQL:
    resolution = "\"Unresolved\"" 
    (info) Another way to make the distinction a little easier between the resolutions is to change the Unresolved status to a different name.
  3. Do a bulk transition using the transition set in step 1.
  4. If necessary, repeat the above steps for each affected status.
  5. Revert the changes made in step 1 to clean up the workflows.
  6. Remove the unresolved status listed under Administration >> Issues >> Resolutions

ScriptRunner Method (third-party app)

This is an alternate method to clear resolutions on tickets

  1. Install the ScriptRunner app.
  2. Build a search for all issues that are using the user created unresolved status. You may use the JQL resolution = "\"Unresolved\""
  3. Save search as a filter.
  4. Built-in Scripts section of ScriptRunner (or directly accessed via <jirabaseurl>/plugins/servlet/scriptrunner/admin/builtin/add/com.onresolve.scriptrunner.canned.jira.admin.BulkFixResolutions)
  5. Select the Bulk Fix Resolutions, use the saved filter, and select None as the new resolution.
  6. Remove the Unresolved status listed under Administration >> Issues >> Issue Attributes >> Resolutions.

Full ScriptRunner usage instructions: https://docs.adaptavist.com/sr4js/latest/features/built-in-scripts/bulk-fix-resolutions

Last modified on Sep 10, 2024

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