Update SLA button in Jira service management does not do any task when it clicked

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When we click the Update SLA button in the project settings, it spins momentarily but doesn't perform any action and then reappears. Ideally, triggering the SLA update button should update the SLA and subsequently disappear.

Environment

Jira Service Management Data Center

Diagnosis

  • When we click the Update SLA button in the project settings, it spins momentarily but doesn't perform any action and then reappears. Ideally, triggering the SLA update button should update the SLA and subsequently disappear.

  • We see the below error in the Jira atlassian-jira.logs.

1 2024-01-01 01:01:01 JiraTaskExecutionThread-7 WARN username [internal.sla.task.ConsistencyTask] The issues with outdate SLAs are not present in the database: 488988

Cause

This issue occurs when Jira Full Reindexing hasn't been run for a long time or if it has been turned off.

Solution

Perform a Full Reindexing and then attempt to update the SLA. Please refer to the below document that will help you to run the Full reindexing in Jira:

Updated on March 4, 2025

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