Updating change dates using Schedule Change option in ticket fails with error "Failed to schedule change"

Summary

When the Agent/Project Admin tries to update change request dates (Planned Start Date and Planned End Date) using the Schedule change button in a Jira issue, the user sees the following error:

Failed to schedule change

                         


Environment

Jira Service Management Cloud

Cause

The following fields are not added to the Edit Screen of the corresponding Issue Type:

  • Planned start or Planned start date
  • Planned end or Planned end date

Solution

Jira Administrators can follow the below steps to add Planned start/Planned start date and Planned end/Planned end date fields in the Edit Screen of the Change Issue Type. These fields are required for Change Requests as referred to in the section Add the date fields to your change request screens

  1. Navigate to the desired Project > Project Settings > Issue Types

  2. Click on Screen Scheme for the Change Issue Type.

  3. Click on the Screen used for Edit Issue 

  4. Add Planned start/Planned start date and Planned end/Planned end date fields

(info) For more information about displaying change requests on the Change calendar, refer to Show change requests on the change calendar

(info) To learn about configuring fields in Screen, refer to Configuring Issue Screen 

In case the issue is still not resolved, feel free to contact Atlassian support.

Last modified on Oct 2, 2024

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