User is unable to edit the fields in the plan as the fields are greyed out.
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
The article provides details of a scenario in which a few users are unable to make changes to the fields in the plan, which is displayed in a read-only mode for them.
Cause
The ability to make changes to the fields in the plan depends on the access level and the project-level permission. For example, a user will need the required permissions in the project and also be a plan user or plan administrator to make changes in the plan view.
Solution
In order to resolve this, you will need to review the permissions for the plan as well as the project.
- For the project, the admin will need to ensure that the user has the "Edit Issues" permission along with the "Schedule Issues" permission (Schedule Issues permission is specifically for editing the dates in the plan)
AND
To review the permissions for the plan, please navigate to the Cog Icon and select Products.
From there, navigate to Plans and then select Permissions.
If the plan appears as read-only, this indicates that the user currently holds the Plans Viewer permission level.
To address this issue, the user must be granted the "Plans User" permission.
Ensure that the user is assigned to the appropriate user groups that are configured with the Plans User permission for edit access.
- Once the user permissions have been updated, the field editing should be successful.