User picker field was not updated by Automation despite status show Success in Cloud
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
Admin used the Edit Issue action to update a User Picker custom field type. However even though the audit log shows the automation status was a success, the user picker field was not updated.
Environment
JIRA Cloud Automation
Diagnosis
- Open the automation that should be updating the field.
- Click Audit log
- Look for logs for the affected issue
- Check for the "Edit Issue" action, it shows, Inactive User
Cause
The Atlassian account that was selected to be the user picker field value was inactive.
Solution
- Check with the site admin or organization admin to verify the Atlassian account status in User Management.
- Open the automation affected.
- Change the "User Picker" field value to a different active Atlassian Account.
- Publish the automation