User presented with an error (A value with ID '10024' does not exist for the field 'project') while accessing Dashboard or Filter
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
User is presented with below error while accessing the Dashboard or Filter
A value with ID '10024' does not exist for the field 'project'.
Diagnosis
- Access the URL <CloudURL>/secure/project/EditProject!default.jspa?pid=10024 (Note the PID is mentioned at the end is from the error)
- Navigate to the permission helper (<CloudURL>/secure/admin/PermissionHelperAdmin.jspa) and select a random request from the project identified above
- For User field select the impacted user
- For issue field select an issue (a random issue)
- For Permission field select "Browse Projects"
- Then hit "Submit" button
- You will find that the impacted user doesn't have browse permission on the particular project
Cause
If the user doesn't have permission to the project from which filter is fetching data, the request will result in a HTTP 400 with an error similar to "HTTP Status 400 - A value with ID '10024' does not exist for the field 'project'."
Solution
Please remove the project above from the filter in question or grant the impacted user to the project for the Dashboard and Filter to work for the specific user.