Users never invited to a restricted JSM project being listed within the customers page


 

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

   

Summary

Your Jira Service Management channel access is set as "Restricted - Only people directly invited to this project can submit requests" according to its customer permissions configuration, however users who were never invited by an agent or project administrator still show up on the project's customers page which is accessible by selecting the Customers option from the service project sidebar.

Cause

Whenever users are granted the Browse Projects permission according to the project's permission scheme they're considered customers, unless they're added to the project as Agents or Project Administrators:



Consequently, they're listed in the project's customers page.

Solution

In case you want such users to be removed from the Customers page, you should either:

  1. Remove users, groups or roles granting the Browse Projects permission from the specific permission scheme or
  2. Updating the project role membership so users with project roles that are granted the Browse Projects permission are removed or
  3. Changing your groups membership by removing any user that is granted the Browse Projects permission. 




Last modified on Sep 28, 2023

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