Using OR Statements in SLA Time Goals
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
When creating SLA Time Goals you have the option to utilize JQL queries to filter Issues into a specific SLA Target for any given SLA. However, sometimes SLA Targets might be incorrect or have an assigned target that is not expected.
Example SLA Goals:
Cause
As you are using OR Statement it essentially creates two JQL queries for the Time Goal, where the Jira Issue can meet either JQL query to populate the SLA. This can cause issues if the SLA Time Goals had similar JQL queries, since the first SLA Target could be assigned. This would create a very short SLA on that Jira Issue and not allow enough time for an Agent to work the ticket. For example, if it's a P4 ticket, but it meets the criteria for the first SLA Target in that first Time Goal (because of the JQL OR statement), it would incorrectly set a different Target than expected. This can cause issues when low priority cases come in which have short SLAs which is not correct.
Solution
In this scenario you could do one of two things:
- Utilize AND statements instead of OR statements only. This would ensure that it must include all of the JQL Queries parameters to populate the SLA with the correct Time Goal Target you expect.
- Continue to use OR Statements, but make them unique enough so that the SLA Time Goal Target does not meet the first SLA Target in the list always. This would ensure the right target is assigned to the SLA on that Jira Issue consistently, without having a very short SLA target when its a Medium or Low SLA Priority ticket for example.
Relevant Articles:
- Create service level agreements (SLAs) to manage goals - https://support.atlassian.com/jira-service-management-cloud/docs/create-service-level-agreements-slas/
- Use advanced search with Jira Query Language (JQL) - https://support.atlassian.com/jira-service-management-cloud/docs/use-advanced-search-with-jira-query-language-jql/