Viewing Jira Service Management Automation rules reveals missing modules

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

Jira Service Management Automation rules are not displayed properly, similar to the following screenshot:


Diagnosis

One or more of the following add-ons are disabled in Jira's universal plugin manager:

  • Service Management Approvals Plugin
  • Service Management Automation Modules Plugin
  • Service Management Notifications Plugin

Inspecting the pluginstate table reveals one or more of the above plugins have been disabled in Jira's database:

select * from pluginstate;

"pluginkey";"pluginenabled"
...
"com.atlassian.servicedesk.approvals-plugin";"false"

Cause

  1. JSDSERVER-5415 - Getting issue details... STATUS
  2. An incompatible plugin is enabled in Jira which is conflicting with Jira Service Management.

Resolution

Always back up your data before performing any modifications to the database. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.

  1. Follow workaround described in JSDSERVER-5415
  2. Review plugins in use by Jira and ensure all are compatible. Incompatible plugins will need to be uninstalled and Jira restarted in order for Jira Service Management dependent add-ons to enable properly


Last modified on Nov 23, 2020

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