We were unable to submit your request

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

When a customer tries to create a request through the Customer portal, an error like below will be shown.

No related stack trace appears to be showing in the logs.

Diagnosis

  1. First, check if there are any required fields in the affected project for that particular Request Type through Project Administration > Request Types > Edit Fields
  2. After it is confirmed that there is a required field, try creating a request with the required field filled and confirmed that the request could be created.
  3. With this, the error appears to be happening when the required field is empty.
  4. This is not expected as by default, the Portal will guide the Customer which field is empty, not showing a banner like above.
  5. Next, back to the Portal and open the browser Development Tools and move to the Network tab.
  6. Replicate the issue and look for 400 Error Code, click on the request to expand the information.
  7. Check the Response whether this is showing:

     

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict
    .dtd"> 
    <html xmlns="http://www.w3.org/1999/xhtml"> 
    <head> 
    <title>IIS 8.5 Detailed Error - 400.0 -  </title> 

Cause

Based on the findings above, it appears that the error is returned by IIS rather than JIRA. An example of the right response when a request could not be created due to a required field is:

{"errors":[{"errorMessage":"Please provide a valid value for field 'Summary'","field":"summary"}],"reasonKey":"cv.request.create.validation.failure","reasonCode":"400"}


Resolution

Make sure that JIRA is integrated with IIS by following the documentation below:

Add the following in the web.config of your IIS:

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
<system.webServer>
         <httpErrors existingResponse="PassThrough" />
</system.webServer>
</configuration>

 

 

Last modified on May 18, 2017

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.