When releasing the version, a warning regarding unresolved issues is displayed, even though these issues are marked as completed.
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
This article provides an overview of the scenario under which certain issues may be considered unresolved during a version release, despite being categorized as having a "done" status.
Environment
Jira Cloud
Cause
In order for an issue to be deemed resolved, two criteria must be met:
The issue must be in the Done status category.
The issue must have a resolution value set.
Therefore, if an issue is regarded as unresolved, it is likely that the resolution field value has not been updated when the issue was transitioned to the Done status.
Solution
A resolution value must be updated for each issue to ensure that it is regarded as completed upon the release of the version. Two scenarios may arise in this context:
The resolution value must be configured for issues transitioning to the "Done" status by utilizing a post function for the transitions that lead to this status.
The resolution value must be updated for issues that are marked as completed, specifically those in the "Done" status that do not have a resolution value assigned.
The steps for updating the resolution value in both scenarios are detailed in this article. Once the workflow has been updated and the resolution field values for the issues have been adjusted, they will be considered as completed when a version is released.