Why can't I see certain fields on the view issue screen in Jira?
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
Some users report they don't see some fields despite the field context being configured correctly, and the fields added to the issue layout.
Cause
The fields that are not populated only show up for the users who have the Edit permissions. If a user doesn't have the Edit Issues permission, they can't populate the empty fields, and will only see what's already populated.
Similarly, if there are multiple tabs on your issue view screen, only the fields that have at least one field populated will be visible to the users without the Edit Issues permission.
Solution
Please follow the below steps to grant the Edit Issues permission to the required user(s)/group(s):
- Go to Project Settings > Permissions.
- Click Actions > Edit Permissions from the top right of the page.
- This will open up the permission schemes page. Select Update against the Edit Issues permission.
- Add the required users, groups, project roles or issue roles.
- Click Update and the change will take effect immediately.
Multiple projects could be using the same permission scheme, so the changes will take effect for all the projects. If you would like to implement the change for one project only without switching to a different permission scheme, you may grant the Edit permission to a particular project role and assign users with the project role only in the required projects.