Why the JSM notification emails delivery status not stored on the domain exchange server when using custom domain email address?

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

Customers who are using custom email addresses for notifications and expecting that the notification delivery status should be available on their exchange as the custom domain is being used.

Cause

The notification emails sent using the custom email address will not be stored on the domain exchange as the emails are triggered using the Atlassian mail server and not the custom domain's exchange server and hence the delivery status will not be available in the exchange server.

Explanation

When a custom email address is configured under notification, Jira itself sends the email as an authorized sender for the configured domain, rather than the domain exchange server. The verification process occurs through DNS and DMARC configuration, as explained in: Add custom email addresses for product notifications

Let's say you have configured a custom email address in your product so that Jira notifications appear like they’re coming directly from your company notification@yourdomain.com

  • When an email notification is sent from Jira on behalf of the custom domain to a user from another domain(joe@acme.com), it is received by the mail server that hosts mail (MX record) for acme.com so that server admin of acme.com will have access to the delivery status. But the mail server admin for domain yourdomain.com will not see the message on their server.
  • When an email is sent from Jira on behalf of your domain to an user from same domain(joe@yourdomain.com), i.e, same domain is used for custom email notification and users. Then, the mail server admin for domain yourdomain.com will have access to the delivery status.

Last modified on Apr 18, 2024

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.