Work Log tab is empty or doesn't display all information

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Problem

When viewing an issue, the Work Log tab is either empty or doesn't display all work logs

However, the History tab shows that work is indeed logged

 

Cause

When entering the work log, the user restricted this entry to certain Roles/Groups

The logs will appear if a user part of this role views the issue

User part of the restricted roleUser not part of the role

 

 

Resolution

If you want all work logs to be displayed, then you will have to manually change the work logs such that they are not restricted

  1. Log in as a user who can view the work log
  2. View the issue's work log tab
  3. For the affected entry, hover over it and click on the pencil icon on the top right of it
  4. Edit the entry so that All Users can view it

 

You can run the following queries against your JIRA database to find the affected issues (these queries are written for PostgreSQL. Modification might have to be made to suit the database your JIRA is using)

  1. To find all work logs which are restricted to certain Roles

    SELECT a.pkey, b.issuenum, c.author, d.name AS "Role" FROM project a JOIN jiraissue b ON a.id=b.project JOIN worklog c ON b.id=c.issueid JOIN projectrole d ON c.rolelevel=d.id WHERE c.rolelevel IS NOT null ORDER BY pkey, issuenum;
    
    
  2. To find all work logs which are restricted to certain Groups

    SELECT a.pkey, b.issuenum, c.author, c.grouplevel FROM project a JOIN jiraissue b ON a.id=b.project JOIN worklog c ON b.id=c.issueid WHERE c.grouplevel IS NOT null ORDER BY pkey, issuenum;

 

Last modified on Feb 26, 2016

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