"Your request could not be created. Please check the fields have been correctly filled in" error while creating requests through Assist
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
Users are encountering the following error when attempting to create requests using Assist on Slack/Teams:
Something went wrong. We were unable to create a ticket. We've notified the agents for this channel. Share this error ID with support: <Error ID>
Users are encountering the following error when attempting to create requests using Assist on Slack/Teams:
An error occured while creating a ticket for this message:
Your request could not be created. Please check the fields have been correctly filled in. Please provide a valid value for field <field name>
Share this error ID with support: <Error ID>
Cause
The field highlighted in the error message is marked as "Required" in either in the connected request type or in the field configuration of the issue type linked to that request type.
Solution
When the field is designated as mandatory, it is imperative to provide a value for this field while creating the request or else you have to mark it as optional. Please follow the below steps to make a field optional: