"Your request could not be created. Please check the fields have been correctly filled in" error while creating requests through Assist

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

Users are encountering the following error when attempting to create requests using Assist on Slack/Teams:

Something went wrong. We were unable to create a ticket. We've notified the agents for this channel. Share this error ID with support: <Error ID>

Users are encountering the following error when attempting to create requests using Assist on Slack/Teams:

An error occured while creating a ticket for this message:

Your request could not be created. Please check the fields have been correctly filled in. Please provide a valid value for field <field name>

Share this error ID with support: <Error ID>


Cause

The field highlighted in the error message is marked as "Required" in either in the connected request type or in the field configuration of the issue type linked to that request type.

Solution

When the field is designated as mandatory, it is imperative to provide a value for this field while creating the request or else you have to mark it as optional. Please follow the below steps to make a field optional:

For request type
  1. From your service project, go to Project settings , and then Request types
  2. Select the request type connected to Assist where this error was seen
  3. In the Request form check if the affected field is marked as "Required"
  4. If yes, uncheck the "Required" option and save the changes
  5. If the Required checkbox is disabled for the field, please review the field configuration to verify if this field is designated as "Required".
For field configuration
  1. From the service project, find which Issue type is associated with the Request type where the error is occured
  2. Navigate to Project Settings, and then Issue Types
  3. Select the field configuration associated with the Issue Type 
  4. In the field configuration find the field and check if its labelled "Required"
  5. If yes, set the field to "Optional" by clicking the optional button in the field configuration.
Last modified on Nov 25, 2024

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