When using MS Teams to create an issue, the error "An unhandled error occurred" is presented if a custom field conditionally required was not filled
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When using MS Teams to create an issue, the error "An unhandled error occurred" is presented if a custom field conditionally required was not filled.
Using MS Teams to create an issue, after the creator fills all the fields marked as required with an "*", the "Create" button is enabled.
After pressing the create button, the following error message is presented:
Error
An unhandled error occurred. We are working on it.
Diagnosis
Using Jira, observe if there are custom fields from third-party vendors using scripts that may turn on or turn off the required option of a field.
Cause
MS Teams for JIRA add-on does not support custom fields from third-party vendors.
- MS TEAMS for JIRA was designed to work with JIRA. It was not designed to be a plugin that integrates functionalities of third-party plugins that we can find in Atlassian Marketplace.
- And the other plugins (probably almost all) were not designed to work in MS TEAMS as well. Their features/functionalities were created to work in JIRA UI, and not in other plugins or APIs, etc.
We do have the following enhancement request opened to add this feature: - API-307Getting issue details... STATUS
Solution
Simplify the Create Issue Screen used on MS teams to not use custom fields from third-party vendors. See our documentation Defining a screen for more details on how to create and edit screens.
After creation of the issue you can edit the issue using Jira Editor to configure the remaining fields.