"SSO 2.0" menu item is not visible in the Administration page after upgrading from Bitbucket Server to Data Center

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

The "SSO 2.0" menu item is not visible in the Administration page after upgrading from Bitbucket Server to Data Center.

A Bitbucket Data Center license has been applied but the "SSO 2.0" link is still not available.

Links for other Data Center features, such as "Clustering" and "Mirrors" are available.

Environment

Bitbucket Server instance that was upgraded to Data Center.

Diagnosis

Manage apps

Look for the "SSO for Atlassian Data Center" or "SAML for Atlassian Data Center" in the list of installed apps and check its status.

  1. Go to Administration > Manage apps

  2. Select "All apps" in the dropdown

  3. Look for "SSO for Atlassian Data Center" or "SAML for Atlassian Data Center"

  4. Check if the plugin is currently disabled

Logs

The key for the plugin is com.atlassian.plugins.authentication.atlassian-authentication-plugin.

The $BITBUCKET_HOME/log/atlassian-bitbucket.log file will show that after the latest restart, the plugin is installed:

1 2021-03-03 15:03:33,106 INFO [FelixDispatchQueue] c.a.p.o.c.f.FelixOsgiContainerManager Installed bundle com.atlassian.plugins.authentication.atlassian-authentication-plugin (105)

However, there is no log entry stating that the plugin has been enabled. Searching for the string "'com.atlassian.plugins.authentication.atlassian-authentication-plugin' is now ENABLED" would not show any matches. There are no errors or warnings in the logs.

Here's a sample log entry that indicates that the plugin was enabled.

1 2021-03-03 20:06:20,929 INFO [spring-startup] c.a.plugin.manager.PluginEnabler Plugin 'com.atlassian.plugins.authentication.atlassian-authentication-plugin' is now ENABLED

Solution

Re-enable the plugin:

  1. Go to Administration > Manage apps

  2. Select "All apps" in the dropdown

  3. Look for "SSO for Atlassian Data Center" or "SAML for Atlassian Data Center"

  4. Click "Enable"

  5. Check that the "SSO 2.0" menu item is now available

Updated on April 8, 2025

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