Publishing a draft results in a "There was an error processing the request" message

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Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

Upon trying to publish a draft, the following error message is displayed:

There was an error processing the request.

Diagnosis

  • Confirm that the page has never been published, keeping it only as a draft.
  • From the browser's console (right-click > InspectNetworkResponse), the following error is displayed:

    {"statusCode":400,"data":{"authorized":false,"valid":true,"errors":[],"successful":false},"message":"com.atlassian.confluence.api.service.exceptions.BadRequestException: Could not publish draft. Parent page has not been published."} 
  • When looking at the breadcrumbs of the draft at the top-right of the page, click on what is supposed to be the parent page and confirm that this is in a draft state. If the page is not displayed, this could mean that this got restricted.

Cause

By default, Confluence does not allow pages to be published without having a parent. In these specific scenarios, some issue happens in which the page itself gets associated with a page that became a draft.

Solution

While editing the draft, move it to a different location:

  1. New editor:
    1. Tap the ellipsis button at the top-right of the draft.
    2. Select Move and move it to a valid location.
  2. Legacy editor:
    1. Near the breadcrumbs, tap the Set location button:
    2. Select a new location.
  3. Publish the draft.

(info) Alternatively:

  • If the parent page's draft can be located in the breadcrumbs, publish the parent page.
  • Contact Atlassian Support to manually set the parent page as a published one via the backend. This is a restricted function for Atlassian in Cloud environments.

Last modified on Feb 4, 2022

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