"We can't create that blueprint right now" message creating a new space
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
When trying to create any spaces, the following error message is displayed:
We can't create that blueprint right now.
Diagnosis
- Make sure that no apps like the deprecated ones described in this KB article:
- Any.do for Confluence
- Atlassian Cards for Confluence.
- Confluence Property Tool
- Confluence universal importer
Upon inspecting the browser's console (right-click > Inspect > Network > Response), the following error is observed:
errorCode: 500, errorType: "UNKNOWN", errorMessage: "Content should not be null"
- After the error message, manually search for the space via the Spaces directory (Spaces > View all spaces) and confirm that it was created, but without a home page.
Cause
Confluence misinterprets the existing content for the Default Space Content template, as if no content existed in it, explaining why the space is still created but does not have a home page.
Solution
Edit the system template, but not necessarily change any content:
- As an administrator of Confluence, go to the instance's administration by tapping the gear icon at the top-right
- Select the Global templates and blueprints option.
- Look for the Default space content template and tap Edit.
- Simply tap Save once the editor is open.
- Going back to the Global templates and blueprints part, tap the Reset to default button on the template's name if no content was edited before. If there was custom content added, this step is not needed.