"Mentioned in" Confluence page is not displaying on individual Jira issues
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Specific Jira issues are referenced in Confluence pages via the default Jira Issues Macro following the Use Jira applications and Confluence together documentation. However, the Confluence page is not showing up in the "Mentioned in" link within the Jira issue.
Environment
Jira + Confluence application links
Diagnosis
- Check that the application links are healthy via ⚙️ → Applications → Application links.
- Confirm the application URLs are updated via the workaround in the suggestion JRASERVER-62850 - Update Confluence Links In JIRA Automatically Based On The New Applink Configurations.
- Confirm the following issues are not occurring:
- Cloning the page fixes the missing "Mentioned in" reference.
Cause
The root cause is unknown at this time.
Solution
- Option 1: Cloning the page and deleting the original one is a workaround for the "Mentioned in" to work properly.
- Option 2: Edit the original page to force Confluence to send another request to Jira to create the "Mentioned in" links in the Jira issue page. For example:
- Go to the original page and remove the issue key and publish the Confluence page.
- Then edit the page again and mention the Jira issue key.