Jira does not start due to "We couldn't start the following plugins" error


Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.

Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Purpose

After restarting Jira Service, Jira fails to load all the required plugins to start the application and the Jira page displays the following error:

"System plugins failed to start: We haven't been able to start all the required system plugins. 

We couldn't start the following plugins:"

<list of plugins>

⚠  You may also see a warning or error in the logs that Jira could not clean the plugin cache during shutdown or startup.

OSGI / cache errors in logs
2022-07-06 11:07:43,084+0100 localhost-startStop-2 INFO      [c.a.jira.plugin.PluginTransactionListener] [plugin-transaction] Shutting down
2022-07-06 11:07:44,788+0100 localhost-startStop-2 WARN      [c.a.p.osgi.factory.OsgiBundlePlugin] OSGi container not running or undefined: Will not remove bundle listener and will not close package admin service


Cause

The most common cause is a failure to clear or rebuild the plugin cache on the application server. 

However, there are other possible causes. 

If clearing the plugin cache does not resolve the issue, please see our Troubleshoot a Jira Server startup failed error KB for other possible causes.

In additional to clearing the plugin cache, you may also need to clear the pluginstate table as detailed in our Jira Startup fails with message that required plugins are not starting KB.

Solution

Manually clear the plugin cache on the application server and the pluginstate table in the database.

  • Stop Jira
  • Delete the <jira_home>/plugins/.bundled-plugins directory (this will be regenerated on restart)
  • Delete the <jira_home>/plugins/.osgi-plugins directory (this will be regenerated on restart)
  • Run this command on the SQL database:
    delete from pluginstate; 

  • Start JIRA


For Jira Data Center

If you have a Data Center instance and you are unable to start Jira after clearing the local plugin cache, then you may also need to clear the shared home plugin cache.  

  • Stop Jira
  • Delete the <shared_jira_home>/plugins/.bundled-plugins directory (this will be regenerated on restart)
  • Delete the <shared_jira_home>/plugins/.osgi-plugins directory (this will be regenerated on restart)
  • Run this command on the SQL database:
    delete from pluginstate; 
  • Start Jira


Additional information

If Jira still fails to start after clearing the plugin cache and clearing the pluginstate table, and the Troubleshoot a Jira Server startup failed error KB does not yield a solution either, please open a support ticket at support.atlassian.com.


DescriptionStartup errors
ProductJira Software, Jira Core, Jira Service Desk



Last modified on Feb 14, 2025

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.