Jira issue links are showing the opposite information between the issue history and the issue panel for the "Blocks" link type

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Jira issue links are showing the opposite/reverse information between the issue history and the issue panel for the "Blocks" link type.

For example, in the screenshot below coming from the issue key SCRUM4-25, we see that:

  • according to the issue history tab: this issue blocks SCRUM4-65

  • however, according to the issue link panel: this issue is blocked by SCRUM4-65

    (Auto-migrated image: description temporarily unavailable)

Environment

Jira Server / Data Center on any version from 8.0.0.

Diagnosis

  • Go to the page ⚙ > Issue > Issue linking and check the inward and outward description for the Blocks link type

  • By default, it should be as below:

    • Outward Description: "blocks"

    • Inward Description: "is blocked by"

      (Auto-migrated image: description temporarily unavailable)
  • If you see that both descriptions have been reversed as shown in the screenshot below, then this KB article is relevant:

    (Auto-migrated image: description temporarily unavailable)
  • Go to the page ⚙ > Manage Apps > Manage Apps:

    • Check if either add-on listed below is installed on version 8.11.x:

      • BigPicture

      • BigGantt

    • If either app is installed on the version mentioned above, and if the problem suddenly happens after upgrading either app, then this KB article is relevant

Cause

If the Outward Description and Inward Description of a specific link type gets reversed (manually or automatically) in the page ⚙ > Issue > Issue linking, the following will happen:

  • For issues that were linked before the configuration change was made:

  • For issues that are linked after the configuration change was made:

    • both the Issue Link panel and the Issue History tab will show the same information and will reflect the new link configuration

Normally, only Jira Admin users can modify the Issue Link configuration via the UI and the page ⚙ > Issue > Issue linking. Unfortunately, it is not possible to see from the Jira Audit logs who (or what) made that change, so the first thing you might consider is asking your Jira Admin users if they changed this configuration by accident.

However, if you found that no user changed this configuration and yet this change suddenly happened for the Blocked issue link, then there is a chance that either the 3rd party app BigPicture or BigGantt caused this issue (if either app is installed in your Jira application and was recently upgraded). There is a known bug with both apps impacting the version 8.11.x which is tracked below:

If the link issue occurred after upgrading either app to version 8.11, then it is likely that you are affected by this bug.

Solution

Go to the page ⚙ > Issue > Issue linking and update the inward and outward description for the Blocks link type so that these descriptions are back to the original versions.

Note:

Please note that changing the configuration back to the default will have the following effect:

Updated on March 24, 2025

Still need help?

The Atlassian Community is here for you.