After a Jira upgrade, getting the error "Uncaught TypeError: n.apply is not a function" when opening any Jira board
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
After a Jira upgrade, the error Uncaught TypeError: n.apply is not a function is thrown in the UI when opening any Jira Agile/Kanban board:
If you are getting a different error in the UI (or if the boards are showing as blank pages), this KB article might be not relevant. Instead, you might want to take a look at the other KB articles listed below, which address different errors thrown when viewing boards:
- After a Jira upgrade, getting the error "Exception: Uncaught TypeError: Cannot read property" when opening any Jira board
- Jira Boards are showing as blank/empty pages
- "Uncaught Error: raven/autocomplete/model missing backbone" when creating or moving issues in Agile boards
Environment
Jira Software Server / Data Center on any version from 9.0.0.
Diagnosis
If the error goes away after entering Plugin Safe Mode from the page ⚙ > Manage Apps > Manage Apps, then it means that there is a 3rd party add-on that is incompatible with the version that Jira was upgraded to.
To identify which add-on is the one causing it, you can follow the steps below:
- Exit plugin safe mode
- Disable each add-on 1 by 1 until the issue goes away
- The last add-on that was disabled is the one that was causing the issue
Cause
There is an 3rd party add-on that is incompatible with the version that Jira was upgraded to.
Solution
Go to ⚙ > Manage Apps > Manage Apps and disable the 3rd party add-on that was identified in the Diagnosis section.
If you need to keep this add-on enabled for your daily operation:
- Try to upgrade it (it is possible that a bug was fixed in a recent version)
- If upgrading it does not resolve the issue, reach out to the support team of the provider of this add-on