"Something went wrong" error message when attempting to review a pull request


 

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

   

Summary

  • Bitbucket Cloud pull requests will fail to load with a "Something went wrong" error message on the diff section. 

Diagnosis

  • When using Bitbucket Cloud's pull request functionality, users will sometimes see the "Something went wrong" error message in the pull request diff. The pull request also doesn't load any diff.
  • This issue is reproducible by all users having access to the repository and can be observed in different browsers.

Cause

There are 2 main causes behind this issue - it is recommended that you check both when troubleshooting this issue:

Cause #1 - Large Diffs

  • This problem is usually caused by very large diffs in pull requests that Bitbucket Cloud UI is unable to handle. You can refer to our documentation for more information regarding the git diff display limits within pull requests. The Bitbucket UI will be unable to load the diff if the size exceeds this limit.
  • There are two possible scenarios, which have slightly different steps to check whether your PR diff exceeds these limits or not:
  1. Pull request already merged through merge commit: If your pull request is already merged, you can check the size of the diff by cloning your repository locally, and performing a three-dot git diff between the two parents of the merge commit, like the example below:

    git diff <parentCommit1>...<parentCommit2> --shortstat

    (info) If you are not sure which commits are the merge commit's parents, you can check that information by navigating to the commit in Bitbucket's UI and checking the "Parents" section on the sidebar.

  2. Pull request not yet merged: If the pull request is not yet merged, you can check the diff size by cloning your repository locally and performing a three-dot git diff between the latest commit of the source branch against the latest commit of the target branch. 

    git diff <sourceBranchCommit>...<targetBranchCommit> --shortstat

Cause #2 - Browser Issues

  • A less common cause behind this issue is that browser extensions such as an AdBlocker are preventing the pull request from loading


Solution #1 - Large Diff

  • If your pull request is exceeding the diff size limit then you can review this diff locally using the below command in your local Git repository:
git diff <commit1>...<commit2>
  • Alternatively, you can make multiple Pull requests with smaller diffs if you would prefer to view the diff in the Bitbucket Cloud UI.

Solution #2 - Browser Issues

If the PR you are attempting to load does not exceed the size limits aforementioned above, the issue may relate to your browser:

  • Attempt to load the pull request in an Incognito window (if using Google Chrome), or alternatively - clearing your browser cache or trying a new web browser to load the pull request to see if this allows you to view the PR
  • It is likely that a browser extension is responsible for causing issues loading the PR, it is recommended that you disable these extensions one-by-one to determine which one is the culprit


If the above instructions do not assist in resolving the issue, please raise a support ticket or raise a community support ticket for further assistance with this.

Description"Something went wrong" error message when attempting to review a pull request
ProductBitbucket Cloud
Last modified on Jan 31, 2024

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.