"Connection lost with Jira Cloud" while accessing Jira issue from Bitbucket Server

robotsnoindex


Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

While accessing a Jira issue from Bitbucket Server UI, seeing the "Connection lost with Jira Cloud" message

Environment

  • Bitbucket Server/Datacenter
  • Jira Cloud

Diagnosis

You'll see the following message when you click on a Jira issue key on the Bitbucket UI:

The below can be seen from the Bitbucket application logs:

atlassian-bitbucket.log
WARN  [http-nio-7990-exec-107] username @1TB8ENDx45XXXXXX 16zxkr0 XX.XXX.X.XXX "GET /rest/jira-integration/latest/issues HTTP/1.0" c.a.i.i.jira.DefaultJiraService Problem communicating with Jira instance 'Jira CLOUD' at '<Jira-Cloud-URL>'. Error: No content to map to Object due to end of input

Bitbucket server and Jira Cloud are connected via Application links as mentioned on this page: Link Bitbucket with Jira and the application link is using OAuth.

Cause

This issue is caused by the bug on the Jira side JSWSERVER-14908. This bug reports a similar error when the app link has been established between Jira and Bitbucket and OAuth user impersonation has been disabled.

Solution

Delete and recreate the Application Link. You may need to delete the link separately on each side before recreating it. After recreating the application link, the users might have to authorize themselves on Jira and Bitbucket.


Last modified on Mar 7, 2025

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.