An error - "Failed to get workspace detail" appears when opening an add-on in Bitbucket
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
When attempting to trigger a Jenkins build via the Jenkins add-on, an error message "Failed to get workspace detail" appears in a popup on the Bitbucket page

Diagnosis
The console logs in the network tab of the browser tools show an error: "USER_ALREADY_DENIED_ACCESS".
This error may occur because the extension has been denied access under Personal Settings of Bitbucket.
This issue is dependent on Personal Settings and not on workspace-level settings, causing some users to see the error while others do not.
Solution
To resolve this issue, you can allow access to any extensions or applications that is requesting for access but has been denied -
Open the URL: https://bitbucket.org/account/settings/app-authorizations/
Check for any applications that have been denied access.
Allow them one by one to identify which application is causing the error.
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