"This app failed to enable. Refer to the logs for more information." error occurring when attempting to enable existing apps or install new apps.
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
The error "This app failed to enable. Refer to the logs for more information" occurs when attempting to enable or install an app in the Jira Administration > Manage apps menu.
Environment
Jira Server/Data Center on any version from 8.0.0.
Diagnosis
In the atlassian-jira.log file you may find that "Unable to start the plugin container for plugin" to have occurred due to missing dependencies.
A known cause for this behavior is due to disabled plugin modules in the pluginstate table. To confirm this execute the query below:
SELECT * from pluginstate where pluginenabled = 'false';
In the results check to see if there are any unexpected modules disabled. If relevant entries are found, ones that belong to the app that is attempting to be enabled, they will need to be deleted.
Solution
- Stop Jira
- Take a backup of the pluginstate table
- Execute the SELECT statement to identify unexpected disabled modules.
Execute the 1st delete statement below for the records that are to be deleted. If you are wanting to delete all records execute the 2nd delete statement.
DELETE from pluginstate where pluginkey = '<insert plugin key here>'; or DELETE * from pluginstate where pluginenabled = 'false';
Start Jira
- Check if plugins now show as enabled or if they are able to be enabled.
- If the behavior persists or if the relevant plugin modules were not found in the pluginstate table please generate a support.zip and raise a request with Atlassian Support.