Subtasks Set to Null due to 'Field Issuetype No Issue Type Selected'
Symptoms
Search results in the Issue Navigator are erroring and not displaying any results. Errors like the following appear in your logs:
2009-06-10 08:10:32,258 http-443-Processor44 WARN [workflow.function.issue.TransitionSubtasksFunction] Field validation error auto-transitioning subtask CXM-957:
2009-06-10 08:10:32,258 http-443-Processor44 WARN [workflow.function.issue.TransitionSubtasksFunction] Field issuetype: No issue type selected.
2009-06-10 08:10:32,383 http-443-Processor44 WARN [workflow.function.issue.TransitionSubtasksFunction] Field validation error auto-transitioning subtask CXM-974:
2009-06-10 08:10:32,383 http-443-Processor44 WARN [workflow.function.issue.TransitionSubtasksFunction] Field issuetype: No issue type selected.
Cause
The Subtask Auto-transition plugin (Now Deprecated) is setting the Issue Type
column in the jiraissue
table to null.
Resolution
- Check if the transition screen that is being auto-transitioned contains issue type. If so, remove it.
To find the issues that have already been set to null, run the following query in the database:
SELECT jiraissue.pkey, jiraissue.issuetype FROM jiraissue LEFT OUTER JOIN issuetype ON ( jiraissue.issuetype = issuetype.id ) where issuetype.pname is null
Last modified on Mar 30, 2016
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