Search or View Issues Cause System Error

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

Trying to search or view issues results in a System Error. The following appears in the atlassian-jira.log:

java.lang.NullPointerException
	at com.atlassian.jira.security.type.GroupCF.getQueryForGroupName(GroupCF.java:105)
	at com.atlassian.jira.security.type.GroupCF.getQueryForGroups(GroupCF.java:97)
	at com.atlassian.jira.security.type.GroupCF.getQueryForSecurityLevel(GroupCF.java:124)
	at com.atlassian.jira.security.type.AbstractIssueFieldSecurityType.getQuery(AbstractIssueFieldSecurityType.java:73)
	at com.atlassian.jira.security.type.GroupCF.getQuery(GroupCF.java:68)
	at com.atlassian.jira.security.type.AbstractIssueFieldSecurityType.getQuery(AbstractIssueFieldSecurityType.java:95)

Cause

There is an error with the issue security scheme permissions returning null value.

Resolution

  1. Go to Administration > Issues > Issue Security Schemes
  2. Check the Security Levels and remove any users/groups that do not actually exist in the system. Also, remove any User Custom Fields, or Group Custom Fields that do not actually exist in the system.
Last modified on Oct 16, 2023

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.