Universal Plugin Manager is Malfunctioning due to "Entry type not found for upm.auditLog.upgrade.plugin.failure"

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Symptoms

UPM is malfunctioning with the following error in the UI:

Entry type not found for upm.auditLog.upgrade.plugin.failure

The following appears in the atlassian-confluence.log:

java.lang.IllegalArgumentException: Entry type not found for upm.auditLog.upgrade.plugin.failure

Cause

  • It's a bug affecting UPM 2.0 UPM-1733 that is fixed in UPM 2.0.3 and higher.
  • Somehow the audit logging of UPM gets corrupted

Workaround

  1. Backup Confluence database for safety purpose.
  2. Remove UPM audit logging manually by running the following SQL query against Confluence database:

    UPDATE BANDANA 
    SET BANDANAVALUE = '<list/>'
    WHERE BANDANAKEY IN ('com.atlassian.upm.log.PluginSettingsAuditLogService:log:upm_audit_log_v3','com.atlassian.upm.log.PluginSettingsAuditLogService:log:upm_audit_log');
    
  3. Restart Confluence 

Resolution

Upgrade your UPM to version 2.0.3 or higher















Last modified on Jul 11, 2019

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