You're visiting the Confluence Knowledge Base. Visit the Confluence Knowledge Base Home for an overview.

Skip to end of metadata
Go to start of metadata

Symptoms

Upgrading to Confluence 3.5 or higher from pre-3.5 failed with the following appears in the atlassian-confluence.log:

Cause

There seems to be some corruption in the Confluence index directory. Or there are some indices that the upgraded Confluence search engine couldn't read. Normally, this failure occurred in the pre-upgrade stage which means that the upgrade tasks haven't started yet at all.

Resolution

  1. Shut down your Confluence server.
  2. Make a backup of your <confluence-home>/index/plugin directory if it exists. This is where the Usage Tracking plugin stores it's index for the usage statistics and it cannot be rebuilt.
  3. Remove the <confluence-home>/index directory.
  4. If in step 2, you have the <confluence-home>/index/plugin directory, create the <confluence-home>/index directory and copy in the backup of <confluence-home>/index/plugin directory made in step 2.
  5. Restart Confluence to re-trigger the upgrade. When you upgrade to Confluence 3.5 or higher, an upgrade task will run automatically to rebuild the index.
Help us improve!
Is this article helpful?
Is it well written?
Is the content complete?