Backup fails when the option "Archive to backups folder" is selected

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

Backup fails when the option "Archive to backups folder" is selected. This problem goes away when "Archive to backups folder" is not selected.

The following appears in the atlassian-confluence.log

 ...
Caused by: java.io.FileNotFoundException: C:\Confluence\Data\attachments\ver003\181\171\1671181\186\93\1343936\1736726 
(The system cannot find the file specified)
	at java.io.FileInputStream.open(Native Method)
	at java.io.FileInputStream.<init>(FileInputStream.java:106)
	at com.atlassian.confluence.pages.persistence.dao.FileSystemAttachmentDataDao.getDataForAttachment
 (FileSystemAttachmentDataDao.java:87)
	... 210 more
2012-05-16 12:23:39,780 ERROR [http-8090-20] [atlassian.confluence.servlet.ConfluenceServletDispatcher] sendError 
Could not execute action
 -- url: /admin/dobackup.action | userName: ddonnelly | referer: http://selasits:8090/admin/backup.action
java.io.IOException: Access is denied
	at java.io.WinNTFileSystem.createFileExclusively(Native Method)
	at java.io.File.createNewFile(File.java:883)
	at com.atlassian.core.util.FileUtils.copyFile(FileUtils.java:465)
...

Cause

This could be a permission issue, or Confluence was started as a different user. Another external factor would be anti-virus/firewall blocking the access.

Resolution

  1. Ensure the right folder permissions on the Confluence home folder by enabling full read and write access or check for the right user that start up the Confluence server.
  2. Check over anti-virus/firewall to see if it is blocking the access.

(info) It is advisable to have a chat with your system admin to see what could possibly cause this permission issue.

Last modified on Feb 23, 2016

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.