Cannot rename users despite upgrading to or installing JIRA 6

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Symptoms

Administrators are still not able to rename Internal Directory users in JIRA, despite upgrading to version 6 or installing version 6. Navigating to Administration > User Management > Users, and clicking on the Edit operation does not show the Username field for editing. 

Cause

You are using JIRA as a user management server for other Atlassian products, such as Confluence and Fisheye. User Renaming is disabled in such situations. To check this, please navigate to Administration > User Management > JIRA User Server. If JIRA is configured to be used as a user management server for other Atlassian products, there will be entries in the JIRA User Server page. 

Workaround

You can set an advanced property in jira-home to allow this, but beware that it can cause known problems for the other products (including other JIRA servers). See the implications below.
Read Advanced JIRA Configuration for details of how to set these properties.

The property is defined as such in jpm.xml:

        <property>
            <key>jira.option.user.crowd.allow.rename</key>
            <name>Allow users to be renamed even when JIRA is acting as a Crowd server</name>
            <description>Controls whether or not the ability to rename a user is enabled when JIRA is configured to act as a Crowd server. This is disabled by default because other applications depending on JIRA's Crowd server implementation will misinterpret a renamed user as having been deleted and created anew.</description>
            <default-value>false</default-value>
            <type>boolean</type>
            <requires-restart>false</requires-restart>
            <admin-editable>false</admin-editable>
            <sysadmin-editable>false</sysadmin-editable>
        </property>

If you are interested in the proper solution, then you may want to watch  JRA-32200 - Getting issue details... STATUS

Recommended Versions

JIRA v6.1.1 and higher now has the ability to correctly publish renames of users to client applications, however for this to work you also need to use an appropriate version of the client application.
Confluence v5.3 or higher is required in order to pick up these username changes correctly.

You will still need to manually set the above option in order to allow renames to happen (JIRA can't tell what version of Confluence is connecting to it, and so will continue to be conservative at least for the JIRA 6.1.x timeframe).

If all the applications are at the recommended version or higher, then setting the jira.option.user.crowd.allow.rename flag is completely safe.
However if any of the applications are not at the recommended version, then the renames will not show up correctly in the client applications - see "Implications" below:

Implications of Workaround for older systems

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The following problem will only occur if you don't upgrade JIRA and the other applications using the JIRA user data to recommended versions as listed in the section above.


Please note that if you remove the JIRA User Server entry, rename a user, and then re-add the user server again, other applications may recognize the renamed user as a new user (see the Update below for when this will work). This can cause quite a lot of problems in other Atlassian products such as Confluence. If Confluence is using JIRA for user management and incremental sync is enabled, a renamed user will show up in Confluence as a new user. If incremental sync is not enabled, then the renamed user will be created and the old user will be lost. (All pages created by the old user will then show its author as Anonymous) Please see this bug report here: https://jira.atlassian.com/browse/JRA-33186


Last modified on Nov 12, 2018

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