PDF Files no Longer Open in Browser, Users are Prompted to Download.

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Symptoms

Beginning on May 20th with the release of Confluence 5.1-OD-9, PDF files are no longer opening in the browser itself, users are being prompted for download.

Cause

The current behavior (Confluence not allowing PDF files to be opened in the browser) is a side effect of a security improvement added to the product. As PDF files can be "active content", the behavior in Confluence will not be reverted.

Workaround

1. Click on cog at the Confluence header and choose "Confluence Admin"
2. Under "Users & Security" choose "Security Configuration".
3. Click any of the "Edit" buttons on the page and find the "Attachment Download Security Policy" section.
4. Select the "Insecure: Display all attachments inline" option and click "Save".


Last modified on Feb 26, 2016

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