Apps disabled with Wrong Type license error in Jira Software

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Symptoms

After updating the JIRA license or upgrading the Universal Plugin Manager Add-on, one or more Add-ons are disabled. When reviewing the Add-ons in the Universal Plugin Manager, the text "Incompatible with Product License (wrong type)" is seen in the License Status field.

Diagnosis

  • License tiers and types match across JIRA and any Add-ons that are installed but Add-ons are disabled with the message "Incompatible with Product License (wrong type)"

Causes

  • The JIRA license is changed from the Commercial type to the Enterprise Commercial type

  • An update of the Universal Plugin Manager introduces a new rule that causes the licenses to be incompatible.


The cause of this is the use of licenses that disagree in Type. For example, there is an Enterprise license type available, that the Universal Plugin Manager 2.7+ will verify that it is compatible with any Add-ons in JIRA

Workaround

If it is critical to get the plugin operational before a new license key can be minted by Atlassian Sales, please go to your my.atlassian.com account and generate an Evaluation license.

Resolution

Depending on the cause, the fix will be different. Please ensure the following:

  • If you're using developer license for plugin, make sure you are also using a developer license in JIRA so the license types are compatible. 
  • Update the UPM to the latest compatible version available to the version of JIRA you are running. 
    • There have been bugs with the compatibility checks on licenses being too restrictive, which are resolved in later versions of the UPM.
  • If you notice your licenses are not compatible, please contact Atlassian at sales@atlassian.com for assistance on converting the licenses.


Last modified on Jul 26, 2023

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