Plugin Manager Doesn't Start Due to 'Duplicate plugin found'

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

After recently installing a plugin either by placing the jar file in <JIRA-HOME>/plugins/installed-plugins/ directory or via the Administration > Plugins page, JIRA's Plugin Manager fails to start up with the following message:

Error occurred while starting Plugin Manager. Duplicate plugin found (installed version is the same or older) and could not be unloaded: 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin'

Cause

There are two different versions of a plugin installed onto the JIRA server.

 

Resolution

Remove all versions of the plugin and re-install the latest compatible version.

A plugin may have been installed in the following locations depending on whether or not it is a Version 2 or Version 1 plugin:

  • First, shutdown JIRA

Version 2:

    • Plugin files are located within: <JIRA-HOME>/plugins/installed-plugins/
    • Remove any *.jar files associated with the problematic plugin

Version 1:

    • Plugin files are generally located within: <JIRA-INSTALL>/atlassian-jira/WEB-INF/lib
      • (info) Note that the plugin may have special instructions beyond the norm. In this case, please refer to the plugin's installation documentation for further info.
    • Remove any *.jar files associated with the problematic plugin
  • Restart JIRA once files have been removed
  • Re-install the plugin via JIRA's Add-on Manager

 

 

 

 

 

 

 

 

 

 

 

 

 

Last modified on Mar 30, 2016

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.