Internet Explorer: "The Requested Content Could Not Be Loaded; Please Try Again Later" error on JPG/JPEG files

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Symptoms

In your instance, some but not all of the JPG attachments appear to be unavailable to any user when using Internet Explorer, but display correctly when viewed in other browsers. 

Diagnosis

To ensure this isn't another issue, please check the following:

  • This affects only JPG/JPEG files
    • Other image types are not affected
  • This affects all users
    • Only when using IE
  • When reviewed in the database, the MIME-type of affected files is listed as image/x-citrix-pjpeg
    • Run the following query; if any results return, you're seeing the issue described in this KB

      SELECT * FROM fileattachment WHERE mimetype = 'image/x-citrix-pjpeg';

Cause

This is caused by a client application from Citrix being used by users in your organisation. Any image downloaded from, or transmitted by, Citrix applications will cause this error.

Workaround

The work around is to change the MIME type for affected files to the correct setting:

Be sure to back up your data before proceeding

UPDATE fileattachment SET mimetype = 'image/jpeg' WHERE mimetype = 'image/x-citrix-pjpeg';

 

 

Resolution

  • To resolve this issue requires changes in user behaviour
  • Users must discontinue the practice of uploading images from Citrix applications
Last modified on Feb 26, 2016

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