Child pages
  • GreenHopper Security Advisory 2012-08-21

Documentation for GreenHopper 6.2.x. Documentation for other versions of JIRA Agile is available too.
GreenHopper is now called JIRA Agile. Learn more.

Skip to end of metadata
Go to start of metadata

This advisory discloses security vulnerabilities that we have found in GreenHopper and fixed in a recent version of GreenHopper.

  • Customers who have downloaded and installed GreenHopper should upgrade their existing GreenHopper plugin to fix this vulnerability.  
  • Enterprise Hosted customers need to request an upgrade by raising a support request at in the "Enterprise Hosting Support" project.
  • Atlassian OnDemand customers are not affected by any of the issues described in this advisory.

Atlassian is committed to improving product security. The vulnerabilities listed in this advisory have been discovered by Atlassian, unless noted otherwise. The reporter may also have requested that we do not credit them. 

If you have questions or concerns regarding this advisory, please raise a support request at

In this advisory:

XSS Vulnerabilities


Atlassian rates the severity level of these vulnerabilities as High, according to the scale published in Severity Levels for Security Issues. The scale allows us to rank the severity as critical, high, medium or low.
This is an independent assessment and you should evaluate its applicability to your own IT environment.


We have identified and fixed several reflected and persisted cross-site scripting (XSS) vulnerabilities that affect GreenHopper instances, including publicly available instances (that is, Internet-facing servers). XSS vulnerabilities allow an attacker to embed their own JavaScript into a GreenHopper page.

You can read more about XSS attacks at, The Web Application Security Consortium and other places on the web.

These vulnerabilities affect all supported versions of GreenHopper, and have been fixed in GreenHopper 5.9.8 and later, including 5.10.x and 6.x. This issue can be tracked here:  GHS-5642 - Getting issue details... STATUS

Risk Mitigation

We strongly recommend upgrading your GreenHopper installation to fix these vulnerability. Please see the 'Fix' section below.



The vulnerabilities and fix versions are described in the 'Description' section above.

We recommend that you upgrade to GreenHopper 5.9.8 (or later), if possible. For a full description of the latest version of GreenHopper, see the release notes. You can download the latest version of GreenHopper from the download centre.

Patches are not available for this vulnerability.



  • No labels