Child pages
  • Agile uses an issue type other than "Epic" as the "Epic" issue type
Skip to end of metadata
Go to start of metadata

Symptoms

An issue type other than "Epic" is being used as the issue type for Epics in JIRA Agile.

If using JIRA Agile 6.3.7 or above, the following appears in the atlassian-greenhopper.log:

Managed Issue Types
	Epic                            id=6                       name=Not Epic                         <<< WARN name is different from expected: Epic (using locale en_US)
	Story                           id=7                       name=Story

Cause

This is caused by the bug GHS-6927 - Getting issue details... STATUS , which means that if there is any issue type that recycled the issue type ID used in a previous install of JIRA Agile, then a new install of JIRA Agile will just use the new issue type instead. Before JIRA 6.1.2, when the bug  JRA-32277 - Getting issue details... STATUS  was fixed, it was possible to recycle the ID of issue types, so this could occur, but it's now not possible. Note that you can be on a later version of JIRA and still be affected by this happening before upgrading.

If when using JIRA 6.1.1 or below, JIRA Agile was installed, then uninstalled, then an issue type id recycled, and then JIRA Agile installed again, you can run into this issue. It's reproducible with the following steps:

  1. Install JIRA Agile
  2. Confirm it's working
  3. Uninstall JIRA Agile
  4. Delete all Issue Types created by JIRA Agile
  5. Create new Issue Types instead of the ones created by JIRA Agile, with different names
  6. Install JIRA Agile again

The fix for GHS-6927 is that the logging will warn when this condition occurs, however due to JRA-32277, in JIRA 6.1.2 and above, it's not possible to create this situation again.

Resolution

Using the example log entry above, you can see that the issue type being used for "Epic" is actually another issue type called "Not Epic". The directions to resolve the issue for this case are listed below in order, for a different issue type name, just replace the names accordingly. If multiple issue types are affected, repeat the steps for each issue type.

  1. Back up JIRA, in case you run into any issues
  2. Create a new issue type with a different name to "Epic" and "Not Epic", for example "Not Epic-TMP"
  3. Go through all of Administration, and for any scheme where "Not Epic" is configured, also configure "Not Epic-TMP" identically, duplicating "Not Epic"'s configuration.
  4. Delete "Not Epic", and when prompted, map all existing issues of that type to "Not Epic-TMP"
  5. Uninstall JIRA Agile
  6. Install JIRA Agile, which will create a new "Epic" issue type with the correct configuration
  7. Rename "Not Epic-TMP" to "Not Epic"
Help us improve!
  • No labels

4 Comments

  1. This is not working on our large instance.

    1. Deleting "Not Epic" issue type is not possible even after reviewing all schemes, so moving issues has been used instead
    2. Reinstalling JIRA Agile is not creating the missing "Epic" status, but managing again another existing issue type "Not Epic 2"

    Seems that this is only working in LAB on empty intance....  (smile)

    Anyone should prefer the SQL queries as stated in  GHS-6927 - Getting issue details... STATUS

    1. Hi Yvan,

      What happens when you try to remove the "Not Epic" issue type, that prevents it from being possible? Would like to understand what the problem is here, and if these instructions are invalid, we will need to fix them.

      If you're still having issues, would you mind please raising a support ticket at https://support.atlassian.com and we can help you from there.

      Regards,

      Dave

  2. Hello,

    I believe I'm having this problem in the cloud version of Jira. After creating 3 epics and a version, a project, teams, categories, accounts and customers, as well as a sample project including the standard sample issues, Then I created a 'workboard'. but none of the version, epics, issues appear in those columns. 

    As a new user of Jira, I'm expecting I don't have the option to create a ticket.

  3. Same problem as first comment but.
    1. Finding all the conf to duplicate was over my head. So I also edited all the issues by hand
    2. Once I had moved all the issues to my "Not Epic Temp" I uninstalled JIRA Agile plugin.
    3. Reinstalled JIRA Agile. and found that the conf was now ok:

     
    Managed Issue Types
    Epic id=10101 name=Epic
    Story id=7 name=Story