Picking a user for the Reporter or Assignee field fails with error after Jira server upgrade

Still need help?

The Atlassian Community is here for you.

Ask the community

Problem

After JIRA upgrade, picking a user from the Reporter or Assignee field throws the following error message when connecting to an LDAP server:
"The JIRA server was contacted but has returned an error response. We are unsure of the result of this operation"

Cause

Some of the JIRA users did not have an email address associated with it. Typing the first letter on the user picker throws the error, typing the second letter makes the user selection worked correctly.

Diagnosis

Diagnostic Steps

Verify whether all of the users in JIRA have an email address associated with it. If there are some users with no email address, add in their email address details:

 SELECT * FROM cwd_user WHERE email_address IS null or email_address = '';

Resolution

  • Update the affected users in the database with valid emails:

    1. Stop JIRA

    2. Run the following SQL query:

      UPDATE cwd_user SET email_address = '<email-address>' WHERE user_name = '<user-from-previous-query>'; 
    3. Start JIRA
  • If the above doesn't change the behavior:
    1. Delete and recreate the LDAP directory
    2. Perform a full sync with the new directory

Last modified on Sep 25, 2019

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.