Incoming Email Handler encounters "Unable to create issue with message.: null"

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Symptoms

A configured email handler for incoming messages does not appear to be working (ie - no issues are being created or no comments being added to existing issues).

Messages similar to the following appear in the atlassian-jira.log:

2014-09-07 15:01:05,542 atlassian-scheduler-quartz1.clustered_Worker-4 WARN ServiceRunner    jira@xxxxx.com Global email replies to JIRA comments [atlassian.mail.incoming.mailfetcherservice] jira@xxxx.com Global email replies to JIRA comments[10700]: Unable to create issue with message.
java.lang.NullPointerException
	at com.atlassian.jira.issue.customfields.impl.DateTimeCFType.getDefaultValue(DateTimeCFType.java:151)
	at com.atlassian.jira.issue.customfields.impl.DateTimeCFType.getDefaultValue(DateTimeCFType.java:56)
	at com.atlassian.jira.issue.fields.CustomFieldImpl.getDefaultValue(CustomFieldImpl.java:1248)

Cause

This is a known issue tracked in JRA-39687.

Resolution

    1. Browse to JIRA Administration > Issues > Custom Fields.
    2. Look for any fields with the Available Context(s) of "Not configured for any context".
    3. Configure them (click on the Cog Icon > Configure).
    4. Edit the configuration.
    5. Select the appropriate context as per Configuring a Custom Field.
    6. Repeat this for all custom fields with the problem "Not configured for any context".
    7. Verify if JIRA is able to create issues from emails.
Last modified on Mar 30, 2016

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