Symptoms

In Service Desk 2.0 and above with public signup, Customers are added into the certain groups and count towards JIRA license. As a result, Service Desk Customers are able to login JIRA and perform actions based on the permission given to the configured groups. 

(info) By default they should not be added into any groups.

Diagnosis

JIRA is configured to external user management such as LDAP or Crowd.

Cause

This is an expected behaviour as Default Group Membership option is enabled for JIRA to LDAP or Crowd, thus new users will be automatically added into the configured group(s), usually jira-users so they can login.

Workaround

Disable Default Group Membership in LDAP or Crowd. 

 

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2 Comments

  1. Thank you for this article, Chung. I'm curious to know if a feature request could be made to prompt users with this Crowd setting to disable it for proper functionality of JSD sign-up.

    1. You're welcome :) In regards to your request, I've raised a Suggestion for it, in which you can watch here ( JSD-1163 - Getting issue details... STATUS ). Let me know if you have any points to add, or you can comment on the ticket directly. 

      Have a nice day!