Unable to upgrade Team Calendars for Confluence to 4.2 or above. Migration to Active Objects failed.

Still need help?

The Atlassian Community is here for you.

Ask the community

Problem

Cannot upgrade to Team Calendars for Confluence 4.2 or above. The Active Objects (AO) tables do not contain data.

You may be unable to enable the Team Calendars for Confluence, or you may simply see empty calendars, or no calendars at all.

Cause

The migration task may not be automatically re-run if it fails. This is being tracked here:  TEAMCAL-2793 - Getting issue details... STATUS  

You may also have incorrect database configuration that is causing the migration to fail.

Resolution

  1. Check your database is configured correctly, with the rights roles/permissions. This varies between databases, see here for the docs for each database system.
  2. Run the migration again by going to <your-confluence-url>/admin/calendar/migratetoactiveobjects.action

 

If you are still having trouble at this point, enable some extra logging and get in touch with Support:

  1. Go to Admin > Logging and Profiling
  2. Add com.atlassian.confluence.extra.calendar3.upgrade.task and set it to DEBUG level
  3. Go to <your-confluence-url>/admin/calendar/migratetoactiveobjects.action and force the migration again
  4. Disable the DEBUG logging
  5. Create a Support Zip and raise a Support Request
Last modified on Feb 26, 2016

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.