Cannot connect with Crowd after upgrade/restore/restart

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Symptoms

After a system restore/restart/upgrade, users will be locked out of Crowd and will be unable to authenticate in JIRA.

The following appears in the atlassian-crowd.log:

2014-12-24 06:57:22,786 http-bio-8095-exec-3 ERROR [crowd.console.action.Login] Failed to connect to the authentication server, please check your crowd.properties
org.springframework.security.authentication.AuthenticationServiceException: Could not invoke service.. Nested exception is org.codehaus.xfire.fault.XFireFault: Server returned error code = 404 for URI : http://your.url.com/crowd/services/SecurityServer. Check server logs for details

Cause

The Crowd Client can't resolve the Crowd Server's URL.

Resolution

Edit the crowd.properties file located in your Home-Directory folder (defined at <Crowd-Install>/crowd-webapp/WEB-INF/classes/crowd-init.properties) so that it can resolve the URL locally.

Replace:

crowd.server.url=http://your.url.com/crowd/services/SecurityServer

with

crowd.server.url=http\://localhost\:8095/crowd/services/

 

(info) You can also use the ip address rather than localhost if you so wish. Ensure that the port number is correct. 

You will need to restart crowd for the changes to take effect.

If this doesn't work for you, clear your browser cookies then try accessing the Crowd client once again. It caches the previous incorrect path, despite making the suggested change above

 

 

Last modified on Mar 30, 2016

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