Error 404 - Problem accessing //
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
When accessing Fisheye/Crucible through a reverse proxy, a 404 is encountered the following is returned in the browser:
<html>
<head>
<meta http-equiv="Content-Type" content="text/html;charset=ISO-8859-1"/>
<title>Error 404 Not Found</title>
</head>
<body>
<h2>HTTP ERROR: 404</h2>
<p>Problem accessing //. Reason:
<pre> Not Found</pre></p>
<hr /><i><small>Powered by Jetty://</small></i>
</body>
</html>
Cause
An extra slash (/
) is being appended to the end of the URL by the proxy server.
Resolution
In Apache make sure that there is no trailing slash for the host URL in the proxy configuration:
ProxyPass /fisheye http://FEHOST:8060/fisheye
ProxyPassReverse /fisheye http://FEHOST:8060/fisheye