First startup of Jira 8 on an upgrade may take a long time

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

The first startup of Jira 8.x when upgrading from Jira 7.x may take several minutes.

Cause

One of the improvements we are shipping to Jira 8.0 is the addition of new indexes to two of the most heavily used tables: 'changeitem' and 'changegroup'. These tables store details on all changes to Jira issues, displayed in the "History" tab when viewing an issue. This should result in reduced loading times for issues and lessen the cost of queries executed against the database to retrieve this data. This is being tracked on  JRASERVER-63002 - Getting issue details... STATUS .

However, creating indexes on these tables that usually contains millions of rows can take several minutes and we have no easy way to track the progress of these processes as they are executed at the database level.

Resolution

Wait for the startup to progress.


DescriptionWhat causes the first startup of Jira 8 after an upgrade to take a long time.
ProductJira, Jira Core, Jira Software, Jira Service Management
Last modified on Nov 23, 2020

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