The error 'Jira Software/Service Management is licensed but not currently installed' is shown in the Versions & Licenses page. (Server and Data Center)

Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

  • You are experiencing a loss of functionality related to Jira Software & Jira Service Management (Creating projects, viewing Boards/Queues etc.).
  • You have recently upgraded/migrated your Jira.

Looking at the Versions & Licenses page, you see the following error thrown.

Diagnosis

Diagnostic Steps


  • For Cause #1, running this query against your database will return results where Jira Software/Service Management module is disabled.

    SELECT * FROM pluginstate where pluginenabled = 'false';

    For example, the query results will be shown as : 

    pluginkey

    pluginenabled
    com.atlassian.jira.plugins.jira-software-plugin:project-navigation-web-panelfalse
    com.atlassian.jira.plugins.jira-software-plugin:version-workload-reportfalse
    com.atlassian.jira.plugins.jira-software-plugin:jira-software-rest-resources-filterfalse

    com.atlassian.servicedesk.application:application

    false

    com.atlassian.jira.jira-software-applicationfalse

    Verify if the 'pluginkey' includes 'jira-software' or 'service desk'.

Cause

Cause #1

Important Jira Software/Service Management modules are disabled.

Cause #2

The Jira Software/Service Management version installed is incompatible with your current Jira version. For example, your Jira Core version is 7.12.3, however, the Jira Software version installed is version 7.10.0.

Resolution

Resolution #1

Always back up your data before performing any modifications to the database. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.

This resolution applies if you're experiencing Cause #1. We will need to enable all the disabled Jira Software/Service Management modules by running this query.

  1. Stop Jira.
  2. Run this query against your database.

    DELETE from pluginstate where pluginenabled = 'false';
  3. Restart Jira.

Resolution #2

Due to this being possibly caused by incompatible Jira versions, try to start Jira without the incompatible jars and check if the issue persists.

  1. Stop Jira
  2. Go to the $Jira-Home/plugins/installed-plugins directory
  3. Rename the $Jira-Home/plugins/installed-plugins directory to $Jira-Home/plugins/installed-plugins2
  4. Start Jira
  5. Install Jira Service Management/Jira Software via UI.

If the issue persists even after following the steps provided above, it is best to create a support request with Atlassian Support for them to analyze which add-on is incompatible and should be removed. We would suggest providing a file list of your plugins directory located in your $Jira_HOME/plugins/installed-plugins by running the terminal command (ls) and copy-paste the list into a text file. 

Description 'Jira Software/Service Management is licensed but not currently installed.' is shown in the Versions & Licenses page.
ProductJira

Last modified on Sep 16, 2024

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