Epic or Story is not showing up on the Schedule view

Still need help?

The Atlassian Community is here for you.

Ask the community

Problem

After creating a Plan from an existing Board that imports Epics and Stories to the Advanced Roadmaps plan, some of the Epics are not showing up on the Scheduled view (set to show Epic), but exist in the Scope view. 

Diagnosis

  1. Cross check the Schedule view with the Scope view and identify which Epic is not showing up.
  2. As observed, usually the Epic will have such error:

    The item is assigned to an invalid sprint.
  3. This error is telling us that the Epic has a sprint that does not belong to the board that is being used in the Plan.
  4. Open the Epic in the Issue View screen and check if the assigned Sprint is from which board.
  5. If the Sprint is being used by more than 1 Board, then you will need to run this SQL to the database to obtain the origin Board; there a feature request in Jira to provide the origin Board information on the UI  JSW-13265 - Getting issue details... STATUS :

    select b."ID", b."NAME" as board_name, s."NAME" as sprint_Name from "AO_60DB71_SPRINT" s, "AO_60DB71_RAPIDVIEW" b where s."NAME" = '<SprintName>' and s."RAPID_VIEW_ID" = b."ID";

    (info) Please replace <SprintName> with the Sprint name from your JIRA.

  6. This SQL will tell you which Board the Sprint was created originally.

  7. If the Epic does not have such error, then the Story under the Epic could be facing this issue. You will need to expand the Epic and check if there is any Epic throwing the invalid sprint error. 
    (info) Closed Stories will not throw such error because by default plans do not include Closed Stories in the Schedule view.

Cause

The origin Board of the involved Sprint is not being included in the Plan as one of the Source. Hence, Advanced Roadmaps could not recognize the Sprint which causes an invalid sprint error.

Resolution

  1. Edit the Plan's Source and include the involved Board.
  2. Since there is new Board, you will need to tweak the Teams - you will need an individual Team to work on each Board.
  3. If the Team is going to be the same team for both Board, you will need to manually create a new Team and add all the same Members into the new team.
  4. Since you have 2 Teams now, you will need to allocate the velocity as your prefer - this is depending on how much each team is going to involved on the each Board.
  5. In the Scope view, find the Epic with the invalid sprint error and update the Team and Member to the new Team and the same Member. When you choose a new Team, the Member list will be refreshed, you will need to make sure the Member is being assigned to correctly based on the information before the update.
  6. Press on the Calculate and the error will be gone. 


Last modified on Aug 23, 2022

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.